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WHAT IS

“VS CODE?"”




Background

« Exists between an Integrated Development
Environment (IDE) and a code editor
IDE:

« Everything needed for software development

« Source-code editor, build automation tools, a debugger all
with a GUI

Code editor:

« Lightweight, fast for writing and running code

« May have simple debugging features
VS Code:

« Open Source, lightweight, cross-platform, fast

« GUI, debugger
« Extensions for extra functionality



Background

Visual Studio Code ° DeVE|Oped by MlcrOSOft |n 2015

Visual Studio

il IDEA « Similar to Visual Studio which is a true IDE

Notepad++ « VS Code focused on being lighter and more accessible

Vim

Android Studio « Windows, Linux, macOS and web browsers

PyCharm O

Jupyter Notebook/JupyterLab

« Open-source

Sublime Text .

Neovim

Eclipse

. « Extremely popular
Nano « Rated #1 on a 2024 survey, 73% of 58,000 respondents
e prefer VS Code

PhpStorm

Rider
DataGrip
VSCodium

IPython

Technology | 2024 Stack Overflow Developer Survey



https://vscode.dev/
https://github.com/microsoft/vscode
https://survey.stackoverflow.co/2024/technology#1-integrated-development-environment

Useful Features

« Debugging
« Cross-platform
« Code refactoring

« Extensions (R, JupyterLab, Python, C,
Visual extensions)

« Version Control Integration with Git

« Bracket matching

SSH to Remote Servers
Customization

Built-in terminal

Many key bind shortcuts

Fast, light-weight



“marketplace”

‘ Search Extensionsin Mark... = Y

Common extensions are free and often
updated

“ INSTALLED

mu Jupyter D 172ms

o

RSl Jupyter notebook support, I...

S —_—
_ _ 2 Microsoft 23]
Extensions may require software to -

already be installed on your computer Jupyter Cell Tags
' Extensmns (Ctrl+Shift+X) )gs support fo...
« Python, Java, etc. 2 Microsoft |_{E}_|



https://marketplace.visualstudio.com/VSCode

Save

o VSCode autosaves frequently
o Ctrl+ S / Ctrl+ Shift + S

o File > Save/Save As..

Run

o Runs your code
o Ctrl + F5

o Run > Run Without Debugging



« Command Palette

o VSCode/Extension Commands
o Crtl + Shift + P

o View > Command Palette...

7

Accounts: Manage Trusted Extensions For Account
Add Data Breakpoint at Address

Add Function Breakpoint

Add XHR/fetch Breakpoint
Calls: Show Call Hierarchy Shift + Alt + H

Calls: Show Incoming Calls

Clamd: A +n Rtk Clad TG

New Window
o Start a new VSCode Window
o Crlt + Shift + N

o File > New Window



USING VSCODE ON

OOD




Code Server

This app will launch a VS Code server using Code Server on the Rivanna/Afton

Cluster. Python users please see instructions.

Rivanna/Afton Partition

Interactive

e |nteractive - (7-24 core) Rivanna/Afton node in the interactive partition.

e Standard - (7-40 cores) Rivanna/Afton node in the standard partition.

® GPU - (7-40 cores) Afton node that has NVIDIA GPU.

* Bii,Bii-gpu - (7-40 cores) Partition for Biocomplexity Institute and Initiative.

# Learn More - Rivanna Queuing Policies
Number of hours

5

Number of cores

3

Memory Request in GB ( maximum 768G )

6

Allocation

hpc_build

Open on Demand

« Interactive jobs on compute nodes
« Access to your files in your HPC Account
« Access to available software modules

https://ood.hpc.virginia.edu



https://ood.hpc.virginia.edu/pun/sys/dashboard/

Code Server

This app will launch a VS Code server using Code Server on the Rivanna/Afton

Cluster. Python users please see instructions.
Rivanna/Afton Partition

Interactive

e |nteractive - (7-24 core) Rivanna/Afton node in the interactive partition.
e Standard - (7-40 cores) Rivanna/Afton node in the standard partition.

® GPU - (7-40 cores) Afton node that has NVIDIA GPU.

* Bii,Bii-gpu - (7-40 cores) Partition for Biocomplexity Institute and Initiative.
[ ]

Learn More - Rivanna Queuing Policies
Number of hours

5

Number of cores

3

Memory Request in GB ( maximum 768G )

6

Allocation

hpc_build

VS Code Server

Keyboard shortcuts don't work
Navigate just as you would on your local
"New Window" opens a new tab
Any changes you make on VS Code Server are on the
cluster
o They don't sync with your local
You don't need to install software on your own

computer



Getting Started...

code-server

Editing evolved
The welcome

page upon launch Start
provides you with
a variety of
options to get
started. Recent

~{local/sharefcode-server/User/Worksp...

/




Open a Folder

Open a Folder:

Select File > Open
Folder...

Appears in the
explorer for easy
navigation

Start

[3 NewFile..

C)ﬁ Open File...

= Open Folder...

:—Q Clone Git Repository...

>< Connect to...

|| File | Edit Selection View Go Run

Recent

New Text File Ctrl+N
New File... Ctrl+Alt+Windows+N
New Window Ctrl+Shift+N
New Window with Profile

Open File... Ctrl+O

Open Folder... Ctrl+K Ctrl+O

EXPLORER

> OPEN EDITORS | 1 unsaved |

v 2022 15ASsOLARWIND [ B O @
> venv
> Documentation
v Notes and Research
v trajectories

» Animation_of_Pioneer_10_trajecto..

.............................................................................

_____________________________________________________________________________

i Animation_of_Ulysses_trajectory.gif
». Animation_of_Voyager_1_trajector...
». Animation_of_Voyager_2_trajector...
(i) Readme.md
v SIC
v Data
v artemis
v afterRonaQs
B Artemis_GSE.csv
B Artemis HGl.csv




Add a Folder

Add a Folder:

Shar “ UNTITLED-1739902204616 (WOR... [} 3
>nare

_ 3k
S e I e Ct F | | e > A d d d Add Folder to Workspace.. 0 > .conda

Folder to Open Folder Settings > hic-pipeline

~ Intro_VSCODE
Remove Folder from Workspace

Works pace... condaenvs.py

> lims_on_hpc

» my_envs

Appears in the > mytestdir
» new_project
explorer for easy

» pycistarget

nav | g a t | on » nvanna-cl

» rivannatest

storagecheck.py

~ xweSk]



Workspaces

S a ve a Wo r ks p a ce n I:lpE‘n WI:'rk"_‘_;pﬂCE' fmr‘n F||E'
/home/xveski/local/share/code-server/User/Workspaces/|

Select File > Save )

Workspace As {} ScratchAndHome.code-workspace ~ SCRATCHANDHOME (WORKSPACE) |

Open a Workspace:

= Settings
Select File > Open
Workspace from File...

User Remote [ood.hpcvirginia.edu] Workspace Folder «
Workspaces are | Commenlyfeed Commonly Used
configurations of your Files: Auto Save
files and folders, so it R Controls of editors that have unsaved changes.
can easily let you access Et afterDelay
yo ur p rOJ e Ct Editor: Font Size

Conflguratlons YOU can Controls the font size in pixels.
even modify specific =
settings!




Installing Extensions

Install
Extensions:

Access the
marketplace in
your web browser

Or the extensions
tab in VS Code

(crtl + shift + x)

Install Python and
Jupyter

Jupyter D 172ms
Jupyter notebook support, I..

& Microsoft

Jupyter Cell Tags
Extensmns (Ctrl+Shift+X) )gs support fc:

Python
Microsoft # microsoft.com ® 155,570,584 ' & . 6.8 & {

o

4 extension access points for IntelliSe

| Disable | Vl ‘ Uninstall ‘V‘ |g tch to Pre-Release Version | \Z| Auto Upda

DETAILS ~ FEATURES  CHANGELOG  EXTENSION PACK

EXTENSIONS

Search Extensions in Mark...

> INSTALLED

> RECOMMENDED

Python extension for Visual Studio Code

A Visual Studio Code extension with rich support for the Python language (for all actively
supported Python versions), providing access points for extensions to seamlessly integrate
and offer support for IntelliSense (Pylance), debugging (Python Debugger), formatting,

linting, code navigation, refactoring, variable explorer, test explorer, and more!

Support for vscode.dev

The Python extension does offer some support when running on vscode.dev (which includes

github.dev). This includes partial IntelliSense for open files in the editor.

Installed extensions




Creating a New File

Create a File: | File | Edit Selection View Go Run

File > New File... \ New Text File Ctrl+N
New File... Ctrl+Alt+Windows+N

Select your file
type

“ VSCODE_INTRO ['?,_ EE 0O & v VSCODE_INTRO
Make sure it is in | NewFile... | = new_file.py
the right folder, or
move it to the
correct folder in
the file explorer on

Select File Type or Enter File Name...

Text File Built-In (ctrl |+[N] File £83
the left . Python File Python
Jupyter Notebook .ipynb Support Notebook




Debugging

« VSCode lets you debug without modifying
your code

« Add breakpoints and view variables be

updated as the code runs RUN AN... & -

~ VARIABLES
~ Locals
> special variables
> function variables

ending_range = 7
> 1st = [2, 3, 5]

starting_range = 2

> Globals



Debugging

Step Intn (F11) ‘

Action

Explanation

Continue / Pause

Continue: Resume normal program/script execution (up

F5 to the next breakpoint).
Pause: Inspect code executing at the current line and
debug line-by-line.
Step Over Execute the next method as a single command without
F10 inspecting or following its component steps.
Step Into Enter the next method to follow its execution line-by-line.
F11
Step Out When inside a method or subroutine, return to the earlier
Shift+F11 execution context by completing remaining lines of the
current method as though it were a single command.
Restart Terminate the current program execution and start
Ctrl+Shift+F5 debugging again using the current run configuration.
Stop Terminate the current program execution.

Shift+F5




Debug a File

Debug a File:

Insert breakpoints
by selecting a line
to place a “red dot”

Run > Start
Debugging

Opens a terminal
automatically

Variables visible on
the left side

Walk through the
debug tools

v VARIABLES
“ Locals
> special variables

» function variables

ending_range = 7
> 1st = [2, 3, 5]
starting_range = 2
> Globals

; |. Run | --- &« > |
Start Debugging
Run Without Debugging

F5
Ctrl+F5




Open a Terminal

Open a Terminal: Fl > bash-4 25
Edit > /home/xveSkj
. Selection > bash-4.4%module list
Terminal > New " >
) - N Currently Loaded Modules:
Te Fmina | =0 1) miniforge/24.3.8-py3.11 2) code-server/4.92.2
Run b
Terminal > New Terminal Ctrl+Shift+’
Help » e e S bagh—4.4$l
Sign out of code-server Run Task...
F rom h ere y ou can Run Build Task... Ctrl+Shift+B
Run Active File
Use regL”ar Run Selected Text
terminal
commands like
i de i Or even |Oad Configure Tasks...

Configure Default Build Task...

modules!




Create a Conda Env

« In a new terminal:
o conda create -n my_env python=3.11 numpy pandas
o conda activate my_env

o pip install matplotlib



Set Your Interpreter

Set Your
Interpreter:

Select your
environment from
your list!

When you run your
code it will run in
your environment.

+ Create Virtual Environment...

B3 Enter interpreter path...

Python 3.11.5 64-bit /bin/python3.11 Recommended

Python 3.13.2 {'vscodeintro’) ~/.conda/envs/vscodeintro/bin/python Conda

Lo L3 o

(vscodeintro) bash-#4_4%/home/xveSkj/ . conda/envs/vscodeintro/bin/python /scratch/xveSkj/Intro VSCODE/condaenvs. py




Run a File

» ~ - 2 new_filepy X ‘D‘ ~ @ '
‘ Run Python File r
0d 0 A e(x, y):
O C Dd ‘ "
‘Run | - &« > |
dpDIe [ 0 i
Start Debugging F5
OdeE
Run Without Debugging Ctrl+F5
D D 0
Debugqging
21 lst = nrime(startine rance. endine ransce)
. N e ~ PROBLEMS QUTPUT DEBUG CONSOLE TERMINAL PORTS Python
C C
- 0 - - PS C:\Users\xveSkj\Documents\VSCode_Intro> & C:/Users/xveSkj/AppData/Local/Programs/Python/Python311/pytho

Documents/VSCode_Intro/new_file.py

Hello! This will be our test file for this introduction
We are going to see all the Prime Numbers on an intervall!
The prime numbers in this range are: [2, 3, 5]

PS C:\Users\xve5kj\Documents\VSCode_Intro>




Jupyter Notebooks

J u p yt er Select a Jupyter Kernel
Noteb Ks: Create your own kernel
OteDOOKS. from a conda
h 2.4, environment:
Select kernel from AMPTorch (20201028) Active Learning /us
. . AMPTorch {20210308) Jusr/: i
the list of available AMPTOrch 0.1 oo et
kernels- or make SE 3.20.1 /
DS5110 -
your own! Julia 1.53 |
Julia 1.6.0 4
Recently Used OCP Models 0.0.3

kernels are
"starred"



https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/
https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/
https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/

Customization

Customization:
v Auto Save Char L

File > Preferences | prefereces > profle efaul

Revert File Settings Ctri+,
These changes stay Close Editor Ctr+F4 Btensions Clrl+Shift+X

. Keyboard Shortcuts Ctri+K Ctri+5

even w h en y ou Close Workspace Ctri+K F ! po——
0 p eén a hew v Confirm Before Close Tacks

Theme

Interactive session

Online Services Settings

You can even

d own | Oa d e Xt Fa EXTEMSIONS: MARKETPLACE L
extensions! auto =Y
Python Auto Import D) dms

Auto-import suggestions for modul..
virgilsisoe &35



LOCAL VS CODE

WITH HPC




UVA Network (VPN or On Grounds)

Strong internet connection

Connects you to the remote host, but keeps
your local preferences



Download SSH Extension

Download SSH
Extension:

Remote - SSH

Microsoft # microsoft.com P 25,417,524 % Kk K x (192)
>— Open any folder on a remote machine using SSH and take advantage of VS Code's full feature...

“Remote - SSH” in
the Marketplace

‘ Disable ‘ ‘ Uninstall ‘C‘ ‘ Switch to Pre-Release Version ‘ |Z| Auto Update |§|

DETAILS  FEATURES  EXTENSION PACK

It is not
necessary but it is
a tool to make it
much easier



Create Connection

Create Connection:

Connect to Host

Enter SSH Connection Command

Add New SSH Host...

‘ ssh -YA xveSI(j@lc:-gin.hpc.virginia.edd
ssh -YA
Press 'Enter’ to confirm your input or ‘Escape’ to cancel

Modify your config file : =

You can later open and edit
the config file as you need

C: > Users > xve5kj > ssh > = config

ForwardAgent yes
User xveS5kj


mailto:mst3k@login.hpc.virginia.edu

You Are Now Connected!

Open Folder
« Now that you are connected you can open up

your workspaces you’'ve created, open your

/home/xveSIg'/i

folders, etc.

- You can see your connection in the bottom bt LB —
I‘ Editing on SSH: login.hpc.virginia.edu

« You still stay connected so long as you stay on
the network



Run an IJob

Run an 1IJob: bash-4.4$ijob -c 6 -A hpc_training -p interactive --time=00:30:00
salloc: Pending job allocation 2523247
Open a new terminal salloc: job 2523247 queued and waiting for resources

i[job -c 6 -A hpc_training -p interactive --time=00:30:00

Starts an ijob on the interactive partition with 6 cores for
30 minutes

Will need to wait for resources to be available

An ijob is specific to the terminal you start it in, you
only have access to those resources in that terminal

The job ends if you close the terminal



Run an IJob

Important Caveats:

This is for running code via terminal commands Run Python File

If you want to run python code you need to “Run Python
File” first, then type in ijob command in that new terminal

Different method for JupyterLab

DO NOT RUN JOBS FROM IJOBS

- 0



Interactive JupyterLab

Interactive JupyterLab:

Start an ijob Existing Jupyter Server...

module load miniforge jupyterlab

jupyter-notebook --no-browser --ip=0.0.0.0 < TE"ISD'f!DW 2.17.0

Copy the url that starts with http://

Create your own kernel
from a conda
environment:

Select your kernel

Existing Jupyter Server

https://www.rc.virginia.edu

Paste Ur—| > Enter /userinfo/howtos/rivanna/c
ustom-jupyter-kernels/

Select your kernel from the kernels we offer or your own!

e —


https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/
https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/
https://www.rc.virginia.edu/userinfo/howtos/rivanna/custom-jupyter-kernels/

ADVANCED

FEATURES




Creating an SSH Key

Creating an SSH Key: C:\Users\xve5kj>ssh-keygen
Generating public/private ed25519 key pair.
New bash terminal (local) Enter file in which to save the key (C:\Users\xve5kj/.ssh/id ed25519):

ssh-keygen
Navigate to your .ssh directory
cat your .pub file and copy it

Log in to remote server and paste
your key in your
/home/id/.ssh/authorized_keys file.
If it does not exist, create it.

Passwordless login!

e —



Source Control with Github

Source Control

v B R |
SOURCE CONTROL

Open a Folder or _
In order to use Git features, you can

Clone a Repository open a folder containing a Git
repository or clone from a URL.

https://github.com/microsoft/vscode-docs.git

Clone from URL https://github.com/microsoft/vscode-docs.git
@ Clone from GitHub

Push/Pull/Commit
‘ Open Folder

Create new

‘ Get started with Git and
branches

Clone Repository GitHub:

To learn more about how to use Git
Even works on HPC and source control in VS Code read

without needing to our docs.

load git module


https://docs.github.com/en/get-started/start-your-journey/hello-world
https://docs.github.com/en/get-started/start-your-journey/hello-world
https://docs.github.com/en/get-started/start-your-journey/hello-world

NEED HELP?
xveSkj@virginia.edu ** hpc-support@virginia.edu
Zoom Office Hours:

Tuesdays 3pm-5pm ** Thursdays 10am-12pm
https://www.rc.virginia.edu/support/



mailto:Xve5kj@virginia.edu
mailto:hpc-support@virginia.edu
https://www.rc.virginia.edu/support/

Hana Parece

xve5kij@virginia.edu

hpc-support@virginia.edu



mailto:Xve5kj@virginia.edu
mailto:Hpc-support@virginia.edu
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